Requirements for using IA-ADAPT

We support a broad range of browsers and environments so you can view video content, complete tests and request continuing education credit.

Supported Browsers

  • Chrome 30+ or Firefox 30+ on Windows with Flash 16+
  • Internet Explorer 9 (or later) on Windows with Flash 11.1+
  • Firefox 30+ or Safari 5+ on Mac OSX
  • iPad
Javascript needs to be turned on to experience the full website
Optimal Browsing Experience

If you want an optimal browsing experience get the latest version of Firefox, Chrome or Internet Explorer 10 (or later). These are excellent browsers that are frequently updated with new features and bug fixes.

Browsers that are not listed in the Supported Browsers section may work for viewing the video content, but we only provide support for the ones listed in the Supported Browsers list.